Script Engine 3.0.25

General discussions related to using the C# Script Engine in APL+Win.

Moderators: Tech Support, phpbb_admin

Script Engine 3.0.25

Postby Ajay Askoolum » June 8th, 2020, 2:36 pm

I am encountering this error:
Code: Select all
      ⎕cse 'GetLastError'
Message: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.
StackTrace:    at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper)
The reason is that the engine is looking for the 64 bit version of the provider and I have the 32 bit version installed (with Office 32-bit). I can use the provider from C# i.e. I do not get the error.

Any workaround?
Ajay Askoolum
 
Posts: 877
Joined: February 22nd, 2007, 2:16 am
Location: United Kingdom

Re: Script Engine 3.0.25

Postby Ajay Askoolum » June 8th, 2020, 4:22 pm

Apologies; this is a duplicate of viewtopic.php?f=27&t=1283
Ajay Askoolum
 
Posts: 877
Joined: February 22nd, 2007, 2:16 am
Location: United Kingdom


Return to APL+Win & The C# Script Engine

Who is online

Users browsing this forum: No registered users and 2 guests

cron